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Windows Domain Network Configuration Guide 
for CCC Pathways 

 

Introduction 

This document reflects the necessary guidelines for configuring your network to run the 
Pathways family of software products using the following supported operating systems: 

Server  
 Windows Server 2003  
 Windows 2000 Server 
 

Workstations  
 Windows Vista Business, Ultimate, or Enterprise 
 Windows XP Professional 
 Windows 2000 Professional 
 

This guide assumes that you are installing Pathways for the first time. And while CCC is 
aware that there are many possible client/server combinations available when setting up a 
network, this document will cover only some of the most common ones. For further 
information, please consult your network technician.  

The Pathways family of products supported in a network environment include: 

 CCC Pathways Appraisal Solution 
 CCC Pathways Estimating Solution 
 CCC Pathways Independent Appraiser Solution 
 
Warning! Setting up a network requires a complete understanding of networking 
theory, as well as a thorough knowledge of all supported operating systems. We 
strongly urge you to enlist the services of a qualified vendor or consultant to install 
and set up your network.  
 
CCC will answer general questions about running Pathways on a network. If you require 
extensive consultation on your network configuration or the various supported operating 
systems, you will need to enlist the services of a qualified network technician. CCC is not 
responsible for the setup or configuration of your internal network systems. 

 
Refer to the appropriate chapter in this Guide to setup and configure your server and 
workstations. This must be completed before installing Pathways. 



2 

Chapter 1 – Windows 2000 Server Domain Server 
Configuration  

Overview 
Pathways is a client/server-based application in which network clients access a single copy 
installed to the network server. Once installed, the server acts as a central repository for all 
program and data files, as well as an internal set of file location pointers. Since these pointers 
reside on the server, they are the same for every workstation accessing Pathways on the 
network.  Consequently, the installation of Pathways must be done to a commonly mapped 
network drive on the server. The installation can either be performed from one of the 
workstations or from the server itself, as long as it is installed to a drive that is common to all 
systems on the network. 

Important! All subsequent Pathways Program, Data and Graphics updates must be 
performed at the same system from which the original installation was run. 
 
In a Windows 2000 domain, the server acts as a single point of authentication for each 
workstation as it logs in. As the server authenticates each user, it determines the access rights 
that user will have both on the server, and on the local workstation. Unlike previous versions 
of Windows, the Windows 2000 Server default access rights are much more restrictive, to the 
point of preventing the basic user from accessing almost all of the local system and 
temporary directories on their workstation. This can present problems during the installation 
or update of Pathways software since some of these files may need to be updated. 
Consequently, during the installation or update of Pathways, the user must be logged onto the 
local workstation with Administrative rights. 

Note Administrator level access is only needed during Pathways installation, Client 
Setup and program updates. The monthly Data and Graphics CD’s can be run by any 
regular Pathways user. 
 
If you are installing Windows 2000 Server for the first time, CCC strongly recommends 
doing a clean installation rather than an upgrade from an existing operating system. This will 
help ensure proper configuration, without any “old baggage” being brought over from the old 
operating system. 

The setup procedures outlined in this guide are provided as an example, and are not meant to 
be the only possible method for configuring your network. However, we strongly suggest 
that your network configuration conforms to these guidelines in order to ensure the success 
of your installation. These instructions assume that your network hardware and software have 
been properly set up and are functioning normally.  

Note If you are running your Windows 2000 Server in a non-domain (workgroup) 
configuration, then configure your server per the instructions outlined in the Windows 
Peer-to-Peer Network Configuration Guide. 
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Configuring the Server 
 
Verify that the server and workstations meet all minimum hardware and software 
requirements as published quarterly in the CCC Technical Requirements document. You can 
find this document located on the CCC website: http://www.cccis.com/. CCC strongly urges 
that the server and workstations meet or exceed our recommended specifications to ensure 
the best performance. 

Verify that you have enough disk space prior to beginning your installation of Pathways. You 
should have at least 4GB of free disk space on your target drive prior to beginning the 
installation. 

Note Although 4GB is sufficient for the installation and operation of Pathways, CCC 
recommends that the target drive be as large as is practical in order to allow plenty of room 
for growth.  

 

Working with Windows Domain Name System (DNS) 

When you create a Windows 2000 Server domain, the DNS service must be running and 
configured. If DNS is not running, it is installed automatically when you create a domain 
controller or when you promote a server to a domain controller. Without the DNS service, 
your Windows workstations may not be able to properly locate the domain controller, and 
thus will not be able to log into the domain. 

 

Configure the network components of the server 

When a Network Interface Card (NIC) is installed, Windows 2000 Server will automatically 
install the following required network components. 

 Client for Microsoft Networks 

 File and Printer Sharing for Microsoft Networks  

 Internet Protocol (TCP/IP) 

 
These are the only components necessary to get the network up and running. And for the 
most part, all of the default settings for these components will work just fine. The only area 
that needs careful consideration is how you plan to assign TCP/IP addresses to your server 
and workstations.  

Note If your network is already set up and running correctly and is configured to use 
the TCP/IP protocol, you may skip to the Create Pathways users and groups section, 
later in this chapter. 

http://www.cccis.com/
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You will have to either use static IP addressing, or a Dynamic Host Configuration Protocol 
(DHCP) server. Static IP addressing is a very reliable way to configure your network. 
However, the downside is that it requires manual configuration at the server as well as at 
every workstation. Windows 2000 Server comes with two flavors of DHCP. It has limited 
DHCP functionality built-in to its Internet Connection Sharing (ICS) feature that is probably 
sufficient for a very small network. It also has a full-featured DHCP server that is better 
suited to a larger network or to small networks needing more flexibility than what is provided 
with ICS. For ease of use and configuration on the part of each workstation, we strongly 
recommend that you utilize one of these DHCP servers. A DHCP server provides automatic 
IP address assignments to all other workstations on the network, thus eliminating the need to 
manually assign them.  

Choose one of following three TCP/IP addressing schemes listed below, and then proceed to 
the appropriate section. 

 DHCP 
 ICS (Choose either an existing or “dummy” connection.) 
 Static IP Addressing 
 

Installing the DHCP Service 

The first step in implementing DHCP is to install the DHCP service. Before you install the 
DHCP service, you should specify a Static IP address, Subnet Mask, and Default Gateway 
address for the network adapter bound to TCP/IP in the computer designated as the DHCP 
server. (Refer to the Configure Static IP addressing section later in this guide if you need 
help with configuring the Static IP settings.) 

 

Install the DHCP service  

1 Log into Windows 2000 Server as an Administrator. 

2 Click Start > Settings > Control Panel. 

3 Double-click Add/Remove Programs, and then click the Add/Remove Windows 
Components icon on the left panel. 

4 Click Networking Services, and then click the Details button.  

5 Click the selection button for the Dynamic Host Configuration Protocol (DHCP) entry in 
the list of subcomponents of Networking Services, and then click OK.  

6 Click Next to install the required components.  

7 If prompted, insert the Windows 2000 Server CD-ROM.  

8 Click Finish, and then close the Add/Remove Programs window.  

9 Close the Control Panel window, and remove the Windows 2000 Server CD-ROM from 
the drive, if used. 
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Note You will be prompted to configure a Static IP if your Local Area Network is 
configured to use a Dynamic IP. 
 

Configuring the DHCP Service 

The basic tasks for configuring the DHCP service are creating a DHCP scope, configuring a 
DHCP scope, and configuring a client reservation. 

 

Creating a DHCP Scope 

After you have installed the DHCP service and it is running, the next step is to create a scope. 
Before a DHCP server can lease an address to DHCP clients, it must have a scope defined. A 
scope is a pool of valid IP addresses available for lease to DHCP clients.  

When creating a DHCP scope, consider the following points: 

 You must create at least one scope for every DHCP server.  

 You must exclude static IP addresses from the scope.  

 You can create multiple scopes on a DHCP server to centralize administration and to 
assign IP addresses specific to a subnet. You can assign only one scope to a specific 
subnet.  

 

Create a DHCP scope  

1 Log into Windows 2000 Server as an Administrator. 

2 Click Start > Programs > Administrative Tools, and then click DHCP.  

3 Right-click the entry for the DHCP server, and then click New Scope. The New Scope 
Wizard window appears.  

4 Click Next from the Welcome screen, and then enter a Name and Description for the 
scope and then click Next.  

5 Enter the range of IP addresses included in the scope and the Subnet mask. (You can 
specify the Subnet mask by length or as an IP address.) Click Next.  

6 From the Add Exclusions window, specify any addresses that must be excluded from the 
scope. (You should at least exclude the address of the server itself, but should also 
include a small range of addresses for statically assigned routers, printers, etc.) Click 
Next.  

Note An exclusion is an address or range of addresses that the server should not 
distribute. You can exclude multiple ranges of addresses. 
 
7 Next, specify how long a client can use an IP address from this scope as issued by the 

DHCP server (For most installations, the default setting of 8 days should work fine.), and 
then click Next.  
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8 From the Configure DHCP Options window, specify that you want to configure common 
DHCP options now, and then click Next.  

9 Specify any routers or default gateways to be used by this scope (you may or may not 
have any), and then click Next. 

10 Enter the parent domain name you want client computers to use for Domain Name 
System (DNS) name resolution. Assuming that you are using the DNS server built-in to 
this Windows 2000 Server, enter the server name and IP address for the local server, 
and then click Next. 

11 From the WINS Servers window, specify the server name and IP address of your 
Windows Internet Name Service (WINS) server (if you have one), and then click Next.  

12 Specify if you want to activate the scope now or later, click Next, and then click Finish.  

13 Optionally, you may need to Authorize the server before it can begin assigning IP 
addesses. Right-click the entry for the DHCP server, and then click Authorize. 

Note Once you have created the scope, you must activate it to make it available for 
lease assignments. 
 
Important! You must delete and recreate a scope to specify a new subnet mask or 
range of IP addresses. 
 
Note If the above section was just completed, skip to the Configure network 
identification settings section later in this chapter. 
 
 

Setting up Internet Connection Sharing  

Setting up Internet Connection Sharing on your Windows 2000 Server is relatively simple 
and painless, and greatly simplifies the task of ensuring that each of the workstations has a 
unique IP address that is correctly defined. If you already have an Internet connection that 
you want to share with the other users on your network, follow the instructions under Share 
an existing Internet connection. To set up a “dummy” connection to allow ICS to 
automatically assign IP addresses to your workstations, follow the instructions under 
Configure a “dummy” ICS connection. 

 

Share an existing Internet connection 

1 Log into Windows 2000 Server as an Administrator. 

2 Click Start > Settings > Network and Dial-up Connections. 

3 Right-click the connection you want to share, and then click Properties.  
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4 Click the Sharing tab at the top of the window and then click the “Enable Internet 

Connection Sharing for this connection” selection button. 

5 If you want others on your network to be able to automatically connect to the Internet, 
then click the “Enable on-demand dialing” selection button, and then click OK. 

 

Important! Once ICS is activated on the system sharing the connection, the IP 
address will automatically change to the static address 192.168.0.1, therefore it may 
lose connectivity to the other stations until they are properly configured. 
 

Note If the above section was just completed, skip to the Configure network 
identification settings section later in this chapter. 
 
 

Configure a Virtual ICS connection 

1 Log into Windows 2000 Server as an Administrator. 

2 Click Start > Settings > Network and Dial-up Connections. 

3 Double-click Make New Connection, and then click Next to continue. 

4 Click Dial-up to private network, and then click Next. 
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5 Enter any 7 digit phone number, and then click Next. 

6 Select For all users, and then click Next. 

7 Click  the “Enable Internet Connection Sharing for this connection” selection button, and 
then click “Enable on-demand dialing” to deselect it. 

8 Click Next, and then click Yes from the Network and Dial-up Connections information 
window. 

9 Enter a name for the connection (e.g., ICS), and click Finish. 

 

Note This will work even if you do not have a modem in the peer server. The 
connection may show a red X on it when finished, but ICS will still automatically 
assign IP addresses to the other workstations. 
 
You must also have two NIC cards installed and configured in order to enable this 
feature. 
 
Important! Once ICS is activated on the system sharing the connection, the IP address 
will automatically change to the static address 192.168.0.1, therefore it may lose 
connectivity to the other stations until they are properly configured. 
 
Note If the above section was just completed, skip to the Configure network 
identification settings section later in this chapter. 
 
 

Configure Static IP addressing 

A Static IP Addressing scheme is a very reliable way to configure your network. However, it 
does require manual configuration as well as an understanding of how TCP/IP addressing 
functions. Another point that must be remembered, is that whenever a new workstation is 
added to the network, it will have to be manually configured as well. To configure your 
server with a Static IP address, follow these simple steps: 

1 Log into Windows 2000 Server as an Administrator. 

2 Click Start > Settings > Network and Dial-up Connections. 

3 Right-click the Local Area Connection, and then click Properties. 

4 Verify that the components listed below are present. (If not, click the Install button to add 
the missing components.) 
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5 Click the “Internet Protocol (TCP/IP)” component, and then click Properties.  

 

Note Additional components are not needed for a simple network installation, and 
can probably be uninstalled. (Consult with your network technician to be certain.) 
 
6 Click the “Use the following IP address” selection button. 
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7 Enter the IP Address and Subnet Mask values in the appropriate fields as displayed 

above, and then click OK. 

CCC recommends using a non-routable address range such as the following: 

Subnet Mask: 255.255.255.0 
Domain Server:  169.254.0.1 
Workstation 1: 169.254.0.10 
Workstation 2: 169.254.0.20 
 

Important! Each system on the network must be configured with a unique IP address. 
 
Note If using DHCP, be sure to exclude the server IP address from the range of 
addresses that the DHCP server will be assigning to its clients. 
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Configure Network Identification settings 

When you create a domain controller or when you promote a server to a domain controller, 
the network identification settings are locked and become unchangeable. Therefore, if you 
did not setup your server name correctly in the beginning, the only recourse is to reinstall. 
(While it is possible to demote your domain controller to make the changes, this process 
wipes out all of your domain and security settings and is not generally recommended.) You 
can view your settings by going through the following steps. 

1 Click Start > Settings > Network and Dial-up Connections. 

2 Click Advanced from the menu bar at the top of the window, and then click “Network 
Identification…” 

       
3 From the Network Identification tab, verify that the server has a unique computer name 

(e.g., PWServer). No other computer on your network should have the same name. 

4 The domain name can be anything you choose, but must be the same on every computer 
on your network. (Once again, the server’s domain name can only be set at the time the 
domain is created.) 

5 Click OK to close the window. 
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Create a logon script for automatic drive mapping 

As stated in the Overview section of this chapter, Pathways requires a common mapped drive 
from all workstations to the share point on the server. In a Windows 2000 Server domain, 
there are several ways of achieving this. The most efficient way would be through Group 
Policy, but due to the complexity and variety of configurations in the field, that type of 
configuration will not be discussed in this guide. For help with configuring a Group Policy, 
please enlist the services of a qualified consultant or network engineer. This leaves either 
mapping from each workstation manually or configuring each user account at the server to 
run a Logon Script. In the interest of dependability as well as centralized administration, 
CCC recommends choosing the latter and therefore will be the only mapping option 
discussed in this guide. 

Follow these steps to create a logon script for Pathways users that will automatically map a 
network drive when the user logs into their workstation. 

1 Log into Windows 2000 Server as an Administrator. 

2 Click Start > Programs > Accessories > Windows Explorer. 

3 Click Tools from the menu bar at the top of the window, and then click Folder Options. 

4 Click the View tab. Verify that the “Hide file extensions for known files types” option has 
no checkmark, and then click OK. 

5 From the Windows Explorer window, expand My Computer (by clicking the Plus sign next 
to it), and then expand the drive that Windows is installed on, (usually drive C). 

6 Keep expanding down the following path: Winnt > Sysvol > Sysvol > (Your Domain 
Name) > Scripts. For help in determining your domain name, see the “Configure Network 
Identification settings” section earlier in this chapter. 

7 Click the Scripts folder. The window displays script files in the right pane. (It may or may 
not be empty depending on your configuration). 

8 From the menu bar, click File > New > Text Document. 

9 Rename the new text document to Pathmap.bat, and then click Yes  when the Rename 
Warning to clear the error message window. 

10 Right-click the Pathmap.bat file you just created, and then click Edit. 

11 The Notepad window appears. Enter the following text (without quotes): “net use p: 
\\servername\cccapps”. Substituting p: for whatever drive letter you decided to use for 
Pathways and replacing “servername” with the actual name of your server. For help in 
determining your server name, see the “Configure Network Identification settings” section 
earlier in this chapter. 

12 Close Notepad. When asked to save changes, click Yes, and then close Windows 
Explorer. 
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Create Pathways users  

1 Log into Windows 2000 Server as an Administrator. 

2 Click Start > Administrative Tools > Active Directory Users and Computers. 

3 Expand the Domain object (by clicking the plus sign next to it). 

4 Right-click the Users folder, and then click New > User. 

       
5 Enter the name “installer” in both the First Name field as well as the User Logon Name 

field, and then click Next. (This account will be used for Pathways installation, Client 
Setup and program update purposes.) 
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6 Enter a password of your choice, and confirm the password. 

7 Click Next, and then click Finish. 

       

Note You may also want to click the “User cannot change password”, “Password 
never expires” selection buttons, or other options at your discretion.  
 
8 In Active Directory User and Computers, right-click the Users folder and then click New > 

User. 
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9 Enter the First Name, Last Name, and User logon name for one of the users who will be 
running Pathways at one of the workstations, and then click Next. 

10 Enter the user’s password, set the password restrictions as appropriate, and then click 
Next. 

11 Review the settings for the new user. If needed, click Back and make any necessary 
changes. When you are satisfied, click Finish.  

12 Repeat steps 8 through 11 for each user who will be running Pathways on the network. 

 

Create Pathways Group 

1 In Active Directory Users and Computers, right-click the Users folder, and then click New 
> Group  

2 Enter “Pathways Users” in the Group Name textbox. 

       
3 From the Group Scope panel, click the Global selection button. 

4 From the Group Type panel, click the Security selection button, and then click OK. 

5 In Active Directory Users and Computers, right-click the Users folder, and then click New 
> Group. 

6 Enter “Pathways Local” in the Group name textbox. 

7 From the Group Scope panel, click the Domain Local selection button. 

8 From the Group Type panel, click the Security selection button, and then click OK.  

9 Right-click the new Pathways Users group on the right side of the window, and then click 
Properties. 
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10 Click the Members tab at the top of the window, and then click the Add button. This will 
bring up a Select Users, Contacts, or Computers window. 

       
11 Click the users you created in the previous steps, and then click Add. 

12 Repeat the above step until you have added all of the users who will be accessing 
Pathways from this server, and then click OK. (Including the “installer” account.) 

13 Click OK to close the Pathways Users Properties window. 

14 Right-click the Pathways Local group on the right side of the window, and then click 
Properties. 

15 Click the Members tab at the top of the window, and then click the Add button. This will 
bring up a Select Users, Contacts, Computers or Groups window. 

16 Click the Pathways Users group, click Add, and then click OK. 

17 Click OK to close the Pathways Local Properties window. 

 

Add the Installer account to the Domain Admins group 

1 Log into Windows 2000 Server as an Administrator. 

2 Click Start > Administrative Tools > Active Directory Users and Computers. 

3 Expand the Domain object (by clicking the plus sign next to it). 

4 Click the Users folder to display its contents in the right window. 

5 Right-click the “installer” account and then click Properties. 

6 Click the Member Of tab, and then click the Add button. The Select Groups window 
appears. 
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7 Click the Domain Admins group, click the Add button, and then click OK. 

8 Click OK to close the “installer” Properties window. 

 

Add a Logon Script to all Pathways user accounts 

1 Log into Windows 2000 Server as an Administrator. 

2 Click Start > Administrative Tools > Active Directory Users and Computers. 

3 Expand the Domain object (by clicking the plus sign next to it). 

4 Click the Users folder to display its contents in the right window. 

5 Right-click one of the Pathways users you created and then click Properties. 

6 From the Profile tab, enter “pathmap.bat” in the Logon script textbox, and then click OK. 

7 Repeat steps 5 and 6 until the script has been added to all Pathways users. (Including 
the “installer” account). 

8 Close Active Directory Users and Computers window. 

 

Create a share point on the server 

1 Log into Windows 2000 Server as an Administrator. 

2 Double-click the My Computer icon on the desktop.  

3 From My Computer, create a new directory on the root of the selected drive (e.g., 
CCCAPPS). This is the directory where Pathways will be installed and will be shared with 
the Pathways users. 

4 Right-click the CCCAPPS directory and then click Sharing.  

5 Click the Share this folder option, leave the Share name set to CCCAPPS, and then click 
the permissions button. 

6 Next, click the Add button. This will bring up a Select Users, Computers, or Groups 
window. 
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7 Add the following groups: Administrators and Pathways Local. Verify that both groups 

have been added, and then click OK. 

8 Click Administrators, and then click Full Control under Allow. Do the same for the 
Pathways Local group. 

       
9 Verify both groups have been added with Full Control access. If not, select the 

appropriate group, and correct the type of access. 
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10 Click the group Everyone, and then click Remove.  

11 Click OK. This will establish CCCAPPS as the shared network drive/directory and will 
grant the Pathways users proper access. 

 

Backup options 

A backup system (such as a removable drive, CD-RW, or a tape drive) is necessary to protect 
you from unexpected disasters that lead to loss of data. CCC strongly recommends that you 
purchase a large-capacity backup system and implement a consistent backup routine that is 
strictly adhered to. Backups should be done as often as is practical. Depending on the need, it 
is best to back up the system on a daily or weekly basis. For help with implementing a 
backup system, please enlist the services of a qualified consultant or network engineer. 

Note The Backup and Restore utility that is installed along with Pathways, was 
primarily designed to ease the move of Pathways from one computer to another in the 
event of computer upgrade or replacement. However, this utility can be used as a 
limited backup system due to its ability to auto run through Windows Task Scheduler. 
 
Important! Pathways Backup and Restore will only backup the Pathways work files 
and configuration files. No program or database files are backed up at all. In the event 
of a system failure, Pathways would have to be reinstalled first, after which the work 
files and configuration files could be restored. 

 
You are now ready to Proceed to the appropriate Windows Domain Client Configuration 
chapter of this guide for instructions on setting up your workstations. 

Note Prior to installing a Pathways product onto a network, the network operating 
system should be correctly installed and functioning on the server, and all 
workstations should be able to successfully attach and login to the server. A qualified 
computer technician should make any necessary adjustments. 
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Chapter 2 – Windows Server 2003 Domain Server 
Configuration  

Overview 
Pathways is a client/server-based application in which network clients access a single copy 
installed to the network server. Once installed, the server acts as a central repository for all 
program and data files, as well as an internal set of file location pointers. Since these pointers 
reside on the server, they are the same for every workstation accessing Pathways on the 
network.  Consequently, the installation of Pathways must be done to a commonly mapped 
network drive on the server. The installation can either be performed from one of the 
workstations or from the server itself, as long as it installed to a drive that is common to all 
systems on the network. 

Important! All subsequent Pathways Program, Data and Graphics updates must be 
performed at the same system from which the original installation was run. 
 
In a Windows Server 2003 domain, the server acts as a single point of authentication for each 
workstation as it logs in. As the server authenticates each user, it determines the access rights 
that user will have both on the server, and on the local workstation. Unlike previous versions 
of Windows, the Windows Server 2003 default access rights are much more restrictive, to the 
point of preventing the basic user from accessing almost all of the local system and 
temporary directories on their workstation. This can present problems during the installation 
or update of Pathways software since some of these files may need to be updated. 
Consequently, during the installation or update of Pathways, the user must be logged onto the 
local workstation with Administrative rights. 

Note Administrator level access is only needed during Pathways installation, Client 
Setup and program updates. The monthly Data and Graphics CD’s can be run by any 
regular Pathways user. 
 
If you are installing Windows Server 2003 for the first time, CCC strongly recommends 
doing a clean installation rather than an upgrade from an existing operating system. This will 
help ensure proper configuration, without any “old baggage” being brought over from the old 
operating system. 

The setup procedures outlined in this guide are provided as an example, and are not meant to 
be the only possible method for configuring your network. However, we strongly suggest 
that your network configuration conforms to these guidelines in order to ensure the success 
of your installation. These instructions assume that your network hardware and software have 
been properly set up and are functioning normally.  

Note If you are running your Windows Server 2003 in a non-domain (workgroup) 
configuration, then configure your server per the instructions outlined in the Windows 
Peer-to-Peer Network Configuration Guide. 
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Configuring the Server 
 
Verify that the server and workstations meet all minimum hardware and software 
requirements as published quarterly in the CCC Technical Requirements document. You can 
find this document located on the CCC website: http://www.cccis.com/. CCC strongly urges 
that the server and workstations meet or exceed our recommended specifications to ensure 
the best performance. 

Please verify that you have enough disk space prior to beginning your installation of 
Pathways. You should have at least 4GB of free disk space on your target drive prior to 
beginning the installation. 

Note Although 4GB is sufficient for the installation and operation of Pathways, CCC 
recommends that the target drive be as large as is practical in order to allow plenty of room 
for growth.  

 

Working with Windows Domain Name System (DNS) 

When you create a Windows Server 2003 domain, the DNS service must be running and 
configured. If DNS is not running, it is installed automatically when you create a domain 
controller or when you promote a server to a domain controller by running the dcpromo 
command. The dcpromo command is used to create the Active Directory environment. 
Without the DNS service, your Windows workstations may not be able to properly locate the 
domain controller, and thus will not be able to log onto the domain. 

 

Configure the network components of the server 

When a Network Interface Card (NIC) is installed, Windows Server 2003 will automatically 
install the following required network components. 

 Client for Microsoft Networks 

 File and Printer Sharing for Microsoft Networks  

 Internet Protocol (TCP/IP) 

 
These are the only components necessary to get the network up and running. And for the 
most part, all of the default settings for these components will work just fine. The only area 
that needs careful consideration is how you plan to assign TCP/IP addresses to your server 
and workstations.  

Note If your network is already set up and running correctly and is configured to use 
the TCP/IP protocol, you may skip to the Create Pathways users and groups section, 
later in this chapter. 

http://www.cccis.com/
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You will have to either use static IP addressing, or a Dynamic Host Configuration Protocol 
(DHCP) server. Static IP addressing is a very reliable way to configure your network. 
However, the downside is that it requires manual configuration at the server as well as at 
every workstation. Windows Server 2003 comes with two flavors of DHCP. It has limited 
DHCP functionality built-in to its Internet Connection Sharing (ICS) feature that is probably 
sufficient for a very small network. It also has a full-featured DHCP server that is better 
suited to a larger network or to small networks needing more flexibility than what is provided 
with ICS. For ease of use and configuration on the part of each workstation, we strongly 
recommend that you utilize one of these DHCP servers. A DHCP server provides automatic 
IP address assignments to all other workstations on the network, thus eliminating the need to 
manually assign them.  

Choose one of following three TCP/IP addressing schemes listed below, and then proceed to 
the appropriate section. 

 DHCP 
 ICS 
 Static IP Addressing 
 

Configuring your server as a DHCP Service 

The first step in implementing DHCP is to install the DHCP service. Before you install the 
DHCP service, you should specify a Static IP address, Subnet Mask, and Default Gateway 
address for the network adapter bound to TCP/IP in the computer designated as the DHCP 
server. (Please refer to the Configure Static IP addressing section later in this guide if you 
need help with configuring the Static IP settings.) 

 

Install and configure the DHCP service using the Manage your Server 
Wizard 

1 Log into Windows Server 2003 as an Administrator. 

2 Click Start > Administrative Tools > Manage Your Server. The Manage Your Server 
window appears. 

3 Click the Add or remove a role link in the Managing Your Server Roles pane. The 
Configure Your Server wizard window appears. 

4 Click Next. The Server Roles window appears. 

5 In the Server Role pane, click the DHCP server link, and then click Next. 

Note If prompted, insert the Windows Server 2003 CD-ROM.  
 
6 The New Scope Wizard appears, click Next. 

7 Enter a Name for the DHCP scope, and then click Next. 
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8 Enter a Start IP address of 169.254.0.10, and then enter 169.254.0.254 for the End IP 
address, and then click Next. 

9 For the Lease Duration, click Next (earlier versions of Server 2003 only). 

10 Right-click the Address Pool components and then click New Exclusion Range. The Add 
Exclusion window appears. 

11 Enter the IP address range to be excluded from the DHCP scope, and then click Add. 

12 When you are finished entering the IP addresses to be excluded, click Close.  

13 The Router window appears, enter 169.254.0.1 for the IP address, click Add, and then 
click Next. 

14 From the Domain Name and DNS Server window, enter a name for the for the Parent 
Domain. 

15 Enter the IP address 169.254.0.1, click Add, and then click Next. 

16 From the WINS Servers page, enter the server name and IP address of your Windows 
Internet Name Service (WINS) server (if you have one), and then click Next.  

17 Click Next to Activate Scope. 

18 Close the Manage Your Server window. 

 

Authorize the DHCP server 

1 Log into Windows Server 2003 as an Administrator. 

2 Click Start > Administrative Tools > DHCP. 

3 When the DHCP management console window appears, right-click the Name of the 
server you created in the previous section, and then click Authorize. 

4 Close the DHCP management console window. 

Note If the above section was just completed, skip to the Configure network 
identification settings section later in this chapter. 
 

Setting up Internet Connection Sharing  

Setting up Internet Connection Sharing on your Windows Server 2003 is relatively simple 
and painless, and greatly simplifies the task of ensuring that each of the workstations has a 
unique IP address that is correctly defined. If you already have an Internet connection that 
you want to share with the other users on your network, follow the instructions under Share 
an existing Internet connection.  

 

Share an existing Internet connection 

1 Log into Windows Server 2003 as an Administrator. 

2 Click Start > Control Panel > Network Connections. 

3 Right-click the connection you want to share, and then click Properties. 
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4 Click the Advanced tab. From the Internet Connection Sharing pane, click the “Allow 
other network to connect” selection button. 

 

Important! Once ICS is activated on the system sharing the connection, the IP address 
will automatically change to the static address 192.168.0.1, therefore it may lose 
connectivity to the other stations until they are properly configured. 
 

Note If the above section was just completed, skip to the Configure network 
identification settings section later in this chapter. 
 
 

Configure Static IP addressing 

A Static IP Addressing scheme is a very reliable way to configure your network. However, it 
does require manual configuration as well as an understanding of how TCP/IP addressing 
functions. Another point that must be remembered, is that whenever a new workstation is 
added to the network, it will have to be manually configured as well. To configure your 
server with a Static IP address, follow these simple steps: 

1 Log into Windows Server 2003 as an Administrator. 

2 Click Start > Control Panel > Network Connections. 

3 Right-click the Local Area Connection, and then click Properties. 

4 Verify that the components listed below are present. (If not, you can use the Install button 
to add the missing components.) 



25 

       
5 Click the Internet Protocol (TCP/IP) component, and then click Properties.  

 

Note Additional components are not needed for a simple network installation, and 
can probably be uninstalled. (Consult with your network technician to be certain.) 
 

6 Click the “Use the following IP address” selection button and  then click the “Use the 
following DNS server addresses” button. 
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7 Enter the IP Address and Subnet Mask values in the appropriate fields as shown, and 

then click OK. 

CCC recommends using a non-routable address range such as the following: 

Subnet Mask: 255.255.255.0 
Domain Server:  169.254.0.1 
Workstation 1: 169.254.0.10 
Workstation 2: 169.254.0.20 
 

Important! Each system on the network must be configured with a unique IP address. 
 
Note If using DHCP, be sure to exclude the server IP address from the range of 
addresses that the DHCP server will be assigning to its clients. 
 

Configure Network Identification settings 

When you create a domain controller or when you promote a server to a domain controller, 
the network identification settings are locked and become unchangeable. Therefore, if you 
did not setup your server name correctly in the beginning, the only recourse is to reinstall. 
(While it is possible to demote your domain controller to make the changes, this process 
wipes out all of your domain and security settings and is not generally recommended.) You 
can view your settings by going through the following steps. 
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1 Click Start > Control Panel > System. 

2 Click the Advanced menu item at the top of the window, and then click Network 
Identification. 

3 Click the Computer Name tab. Verify that the server has a unique computer name (e.g., 
PWServer). No other computer on your network should have the same name. The 
domain name can be anything you choose, but must be the same on every computer on 
your network. (Once again, the server’s domain name can only be set at the time the 
domain is created.) 

4 Enter any changes needed, and then click OK. 

 

Create a logon script for automatic drive mapping 

As stated in the Overview section of this chapter, Pathways requires a common mapped drive 
from all workstations to the share point on the server. In a Windows Server 2003 domain, 
there are several ways of achieving this. The most efficient way would be through Group 
Policy, but due to the complexity and variety of configurations in the field, that type of 
configuration will not be discussed in this guide. For help with configuring a Group Policy, 
please enlist the services of a qualified consultant or network engineer. This leaves either 
mapping from each workstation manually or configuring each user account at the server to 
run a Logon Script. In the interest of dependability as well as centralized administration, 
CCC recommends choosing the latter and therefore will be the only mapping option 
discussed in this guide. 

To create a logon script for Pathways users that automatically maps a drive when they log 
onto Windows, please follow these steps: 

1 Log into Windows Server 2003 as an Administrator. 

2 Click Start > Programs > Accessories > Windows Explorer. 

3 Click Tools from the menu bar at the top of the window, and then click Folder Options. 

4 From the View tab, verify that the “Hide file extensions for known files types” selection 
button has no checkmark, and then click OK. 

5 From the Windows Explorer window, expand My Computer (by clicking the Plus sign next 
to it), and then expand the drive that Windows is installed on, (usually C:). 

6 Keep expanding down the following path: Windows > Sysvol > Sysvol > (Your Domain 
Name) > Scripts. For help in determining your domain name, see the “Configure Network 
Identification settings” section earlier in this chapter. 

7 Click the Scripts folder in order to display the files on the right screen. (It may or may not 
be empty depending on your configuration). 

8 From the menu bar, click File > New > Text Document. 

9 Rename the new text document to Pathmap.bat, and then click Yes on the Rename 
Warning. 

10 Right-click the Pathmap.bat file you just created, and then click Edit. 

11 The Notepad window appears. Enter the following text (without quotes): “net use p: 
\\servername\cccapps”. Substituting p: for whatever drive letter you decided to use for 
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Pathways and replacing “servername” with the actual name of your server. For help in 
determining your server name, refer to the “Configure Network Identification settings” 
section earlier in this chapter. 

12 Close Notepad. Click Yes to save the changes, and then close Windows Explorer. 

 

Create Pathways users 

1 Log into Windows Server 2003 as an Administrator. 

2 Click Start > Settings > Control Panel. 

3 From Control Panel, open Administrative Tools, and then open Active Directory Users 
and Computers. 

4 Expand the Domain object (by clicking the plus sign next to it). 

5 Right-click the Users folder, and then click New > User. 
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6 Enter the name “installer” in both the First Name field as well as the User Logon Name 
field, and then click Next. (This account will be used for Pathways installation, Client 
Setup and program update purposes.) 

       
7 Enter a password of your choice, confirm the password, click Next, and then click Finish. 

      

Note You may also want to select “User cannot change password”, “Password never 
expires”, or other options at your discretion.  
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8 In Active Directory User and Computers, right-click the Users folder, and then click New > 
User. 

9 Enter the First Name, Last Name, and User logon name for one of the users who will be 
running Pathways at one of the workstations, and then click Next. 

10 Enter the user’s password, set the password restrictions as appropriate, and then click 
Next. 

11 Review the settings for the new user. If needed, click Back and make any necessary 
changes. When you are satisfied, click Finish.  

12 Repeat steps 8 through 11 for each user who will be running Pathways on the network. 

 

Create Pathways group 

1 From the Active Directory Users and Computers, right-click the Users folder, and then 
click New > Group.  

2 Enter “Pathways Users” in the Group name textbox. 

 

       
3 From the Group scope panel, click the Global selection button. 

4 From the Group type panel, click the Security selection button, and then click OK. 

5 From the Active Directory Users and Computers window, right-click the Users folder, and 
then click New > Group. 

6 Enter “Pathways Local” in the Group name textbox. 

7 From the Group scope panel, click the Domain Local selection button. 

8 From the Group type panel, click the Security selection button, and then click OK.  
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9 Right-click the new Pathways Users group from the right side of the window, and then 
click Properties. 

10 Click the Members tab at the top of the window, and then click Add. The Select Users, 
Contacts, or Computers, window appears. 

        
11 Click Advanced, and then click Find Now.  

12 Click the users you created in the previous steps, and then click Add. 

Note You can select multiple users by holding down the Ctrl key and then click on 
each user. 
13 When you have finished adding all of the users who will be accessing Pathways from this 

server, click OK. (Including the “installer” account.) 

14 Click OK to close the Pathways Users Properties window. 

 

Add the Installer account to the Domain Admins group 

1 Log into Windows Server 2003 as an Administrator. 

2 Click Start > Settings > Control Panel. 

3 From Control Panel, click Administrative Tools, and then click Active Directory Users and 
Computers. 

4 Click the plus sign next to the Domain object to expand. 

5 Click the Users folder to display its contents in the right window. 

6 Right-click the “installer” account, and then click properties. 

7 Click the Member Of tab, and then click Add. The Select Groups window appears. 

8 Click the Domain Admins group, click Add, and then click OK. 

9 Click OK to close the “installer” Properties window. 

 

Add a Logon Script to all Pathways user accounts 

1 Log into Windows Server 2003 as an Administrator. 

2 Click Start > Settings > Control Panel. 
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3 From Control Panel, click Administrative Tools, and then click Active Directory Users and 
Computers. 

4 Click the plus sign next to the Domain object to expand. 

5 Click the Users folder. The User appear in the right window. 

6 Right-click one of the Pathways users you created, and then click Properties. 

7 From the Profile tab, enter “pathmap.bat” in the Logon script field, and then click OK. 

8 Repeat steps 6 and 7 above until the script has been added to all Pathways users. 
(Including the “installer” account). 

9 Close Active Directory Users and Computers. 

 

Create a share point on the server 

1 Log into Windows Server 2003 as an Administrator. 

2 Double-click the My Computer icon on the desktop.  

3 In My Computer, create a new directory on the root of the selected drive (e.g., 
CCCAPPS). This is the directory where Pathways will be installed and will be shared with 
the Pathways users. 

4 Right-click the CCCAPPS directory, and then click Sharing.  

5 Click the Share this folder selection button, leave the Share name set to CCCAPPS, and 
then click the permissions button. 

6 Next, click Add. The Select Users, Computers, or Groups window appears.  

       
7 Click Add, and then enter Administrators and Pathways Local. 

8 Click Check Names. Make certain that both groups have been added, and then click OK. 

9 Click Administrators, and then click the Full Control Allow selection button. Do the same 
for the Pathways Local group. 



33 

       
10 Confirm that both groups have been added with Full Control access. If not, select the 

appropriate group, and correct the type of access. 

11 Click the group Everyone and then click Remove.  

12 Click OK. This establishes CCCAPPS as the shared network drive/directory and will grant 
the Pathways users proper access. 

 

Backup options 

A backup system (such as a removable drive, CD-RW, or a tape drive) is necessary to protect 
you from unexpected disasters that lead to loss of data. CCC strongly recommends that you 
purchase a large-capacity backup system and implement a consistent backup routine that is 
strictly adhered to. Backups should be done as often as is practical. Depending on the need, it 
is best to back up the system on a daily or weekly basis. For help with implementing a 
backup system, please enlist the services of a qualified consultant or network engineer. 

Note The Backup and Restore utility that is installed along with Pathways, was 
primarily designed to ease the move of Pathways from one computer to another in the 
event of computer upgrade or replacement. However, this utility can be used as a 
limited backup system due to its ability to auto run through Windows Task Scheduler. 
 
Important! Pathways Backup and Restore will only backup the Pathways work files 
and configuration files. No program or database files are backed up at all. In the event 
of a system failure, Pathways would have to be reinstalled first, after which the work 
files and configuration files could be restored. 
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You are now ready to Proceed to the appropriate Windows Domain Client Configuration 
chapter of this guide for instructions on setting up your workstations. 

Note Prior to installing a Pathways product onto a network, the network operating 
system should be correctly installed and functioning on the server, and all 
workstations should be able to successfully attach and login to the server. A qualified 
computer technician should make any necessary adjustments. 
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Chapter 3 – Windows Vista Domain Client Configuration  

Configure the Workstations - Overview 
The Domain login feature is available on Windows Vista Business, Windows Vista Ultimate 
, and Windows Vista Enterprise. Verify that the server and workstations meet all minimum 
hardware and software requirements as published quarterly in the CCC Technical 
Requirements document. You can find this document located on the CCC website: 
http://www.cccis.com/. CCC strongly urges that the server and workstations meet or exceed 
our recommended hardware specifications to ensure the best performance.  

When a Network Interface Card (NIC) is installed, Windows Vista Workstation will 
automatically install the following required network components and services.  

 TCP/IP Protocol 

 Computer Browser  

 NetBIOS Interface 

 RPC Configuration 

 Server 

 Workstation 

 
These are the only components necessary to get the network up and running. And for the 
most part, all of the default settings for these components will work just fine. The only area 
that needs careful consideration is how you plan to assign TCP/IP addresses to your 
workstations. 

Note If your network is already set up and running correctly, and it is configured to 
use the TCP/IP protocol, then you may skip to the Configure Network Identification 
settings and join the domain section, later in this chapter. 
  
The type of TCP/IP addressing scheme needed for the workstations, is determined by the 
design that was previously chosen for the server.  

Choose from the list below, the same TCP/IP addressing scheme that was configured for the 
server, and then proceed to the appropriate section within this chapter. 

 ICS or Automatic Private IP Addressing 
 Static IP Addressing 
 

 

http://www.cccis.com/
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Configure clients for DHCP or ICS 

Whether you are going to use ICS or Automatic Private IP Addressing, the workstation 
configuration is identical. To verify that you have all of the necessary components and their 
configurations for this type of setup, follow these steps on each of your Workstation systems: 

1 Log into Windows Vista as an Administrator. 

2 Click Start > Control Panel > Network and Internet > Network and Sharing Center. 

3 From the Private Network pane, click the View status link. The Local Area Connection 
Status window appears. 

4 Click the Properties button. The Local Area Connection Properties window appears. 

        

Note Additional components are not needed for a simple network installation. 
(Consult with your network technician to be certain.) 
 
5 Click the Internet Protocol Version 4 (TCP/IPv4) component, and then click Properties.  

6 Click the “Obtain an IP address automatically” selection button, and then click OK.  

7 Click OK to close the Local Area Connection Properties window. 
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Note If the above section was just completed, skip to the Configure network 
identification settings and join the domain section later in this chapter. 

 

Configure Static IP Addressing 

To configure your Windows Vista Workstations with Static IP addresses, please follow these 
simple steps: 

1 Log into Windows Vista as an Administrator. 

2 Click Start > Control Panel > Network and Internet > Network and Sharing Center. 

3 From the Private Network pane, click the View status link. The Local Area Connection 
Status window appears. 

 

4 Click the Properties button. The Local Area Connection Properties window appears. 

5 Click the Internet Protocol Version 4 (TCP/IPv4) component, and then click Properties.  

6 Click the “Use the following IP address” selection button. 
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CCC recommends using a non-routable address range such as the following: 

Workstation 1 IP Address: 169.254.0.10 
Workstation 2 IP Address: 169.254.0.20 
Subnet Mask:  255.255.255.0 
Peer or Default Gateway:  169.254.0.1 
 

Important! Each system on the network must be configured with a unique IP 
address. You must also enter your DNS server IP address. Consult your network 
administrator. 
 
7 When you are finished, click OK to close the Internet Protocol Version 4 (TCP/IPv4) 

Properties window. 

8 Click Close. The Local Area Connection Status window closes. 

 

Configure Network Identification settings and join the domain 

1 Log into Windows Vista as an Administrator. 

2 Click Start > Control Panel, and then double-click System (In Classic View mode). 

3 From the Computer name, domain, and workgroup pane, click the Change settings link. 
The System Properties window appears. 

4 Click the Change button. The Computer Name/Domain Change window appears. 

5 Click the Domain selection button, and then enter the domain name in the Domain 
textbox. 

6 Click OK. The Windows Security login window appears. 
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7 Enter the User name and Password of the domain admin user that you set up earlier, and 
then click OK.        

8 From the Welcome screen, click OK, and then click Close. 

9 When prompted to restart the computer, click Yes. 

 

Authenticate on the domain  

1 From the Windows Vista login window, click the Pathways user Login tile. 

2 Enter the Domain name\username in the User Name textbox, and then enter the 
password of the user who will be running Pathways at this workstation, and then click the 
right arrow icon. 

 

Note You must be logged into the domain as “installer” in order to perform Pathways 
installation, Client Setup, or program updates. 
 

Access Rights 

One of the features of Windows Vista is increased security. System administrators have 
much greater control over user access to network resources as well as control over user rights 
and access to the local system. Pathways requires that users have Full Control of both the 
installation files that reside on the server as well as the Pathways directory that resides 
locally on each workstation. In order to install, or update the Pathways program, the user 
must have Administrator level access. This is due to the fact that during the installation or 
update, program components are being installed and entries are made to the Windows 
Registry. 

Note Administrator level access is only needed during Pathways installation, Client 
Setup and program updates. The monthly Data and Graphics CD’s can be run by any 
regular Pathways user. 
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Important! Once Pathways is installed and Client Setup has been run, proper access 
rights will need to be applied to the local Pathways folder created during the Client 
Setup process. This includes the server if planning to run Pathways from that station 
as well. See the Network Installation & Update Guide for Pathways for details. 
  
You are now ready to proceed with the installation of your Pathways product. Please 
refer to the Network Installation & Update Guide for Pathways for more information. 
 
Note Prior to installing a Pathways product onto a network, the network operating 
system should be correctly installed and functioning on the server, and all 
workstations should be able to successfully attach and login to the server. A qualified 
computer technician should make any necessary adjustments. 
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Chapter 4 – Windows XP Professional Domain Client 
Configuration  

Configure the Workstations - Overview 
Verify that the server and workstations meet all minimum hardware and software 
requirements as published quarterly in the CCC Technical Requirements document. You can 
find this document located on the CCC website: http://www.cccis.com/. CCC strongly urges 
that the server and workstations meet or exceed our recommended hardware specifications to 
ensure the best performance. 

When a Network Interface Card (NIC) is installed, Windows XP Professional will 
automatically install the following required network components. 

 Client for Microsoft Networks 

 File and Printer Sharing for Microsoft Networks  

 Internet Protocol (TCP/IP) 

 
These are the only components necessary to get the network up and running. And for the 
most part, all of the default settings for these components will work just fine. The only area 
that needs careful consideration is how you plan to assign TCP/IP addresses to your 
workstations. 

Note If your network is already set up and running correctly, and it is configured to 
use the TCP/IP protocol, then you may skip to the Configure Network Identification 
settings and join the domain section, later in this chapter. 
 
The type of TCP/IP addressing scheme needed for the workstations, is determined by the 
design that was previously chosen for the server.  

Choose from the list below, the same TCP/IP addressing scheme that was configured for the 
server, and then proceed to the appropriate section within this chapter. 

 ICS or Automatic Private IP Addressing 
 Static IP Addressing 

http://www.cccis.com/
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Configure clients for DHCP or ICS 

Whether you are going to use ICS or Automatic Private IP Addressing, the workstation 
configuration is identical. To verify that you have all of the necessary components and their 
configurations for this type of setup, follow these simple steps on each of your XP 
Professional workstations: 

1 Log into Windows XP as an Administrator. 

2 Click Start > Control Panel. 

3 Click Network and Internet Connections, and then click Network Connections. If set to 
Classic View mode, double-click Network Connections.  

Note If you’re in Classic View mode, the link will read, “Switch to Category View”. 
If you’re in Category mode, the link will read, “Switch to Classic View”. 
 
4 Right-click the Local Area Connection, and then click Properties. The Local Area 

Connection Properties window appears. 

5 Verify that the components listed below are present. (If not, you can use the Install button 
to add the missing components.) 
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Note These are the only components necessary to get the network up and running. 
Additional components are not needed, and can probably be uninstalled. (Consult 
with your network technician to be certain.) 
 
6 Click the Internet Protocol (TCP/IP) component, and then click the Properties button. 

7 Click the “Obtain an IP address automatically” selection button, and then click the “Obtain 
DNS server address automatically” selection button. 

       
8 When you are finished making changes, click OK to close the Internet Protocol (TCP/IP) 

Properties window. 

9 Click OK to close the Local Area Connection Properties window. 

 

Note If the above section was just completed, skip to the Configure network 
identification settings and join the domain section later in this chapter. 
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Configure Static IP Addressing 

To configure your XP Professional clients with Static IP addresses, Please follow these 
simple steps:  

1 Log into Windows XP as an Administrator. 

2 Click Start > Control Panel, and then double-click Network Connections. The Network 
Connections window appears. 

Note Refer to the Configure ICS or Automatic Private IP Addressing section earlier 
in this chapter if you need help with navigating to the Network Connections window. 

3 From the Network Connections window, right-click the Local Area Connection, and then 
click Properties.  

4 Click the Internet Protocol (TCP/IP) component, and then click the Properties button. The 
Internet Protocol (TCP/IP) Properties window appears. 

5 Click the “Use the following IP address” selection button. 

       
6 Enter the IP Address and Subnet Mask values in the appropriate fields as shown above, 

and then click OK. 

CCC recommends using a non-routable address range such as the following: 

Workstation 1 IP address: 169.254.0.10 
Workstation 2 IP address: 169.254.0.20  
Subnet Mask:  255.255.255.0 
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Peer or DNS Server:  169.254.0.1 
 

Important! Each system on the network must be configured with a unique IP address. 

 

Configure Network Identification settings and join the domain 

1 Log into Windows XP as an Administrator.  

2 Click Start > Control Panel, and then double-click Network Connections. The Network 
Connections window appears. 

Note Refer to the Configure ICS or Automatic Private IP Addressing section earlier 
in this chapter if you need help with navigating to the Network Connections window. 

3 From the Network Connections window, Click Advanced from the menu bar at the top of 
the window, and then click “Network Identification…”. The System Properties window 
appears. 

       
4 From the System Properties  window, click the Computer Name tab. Verify that the 

workstation has a unique computer name (e.g., Workstation1). No other computer on 
your network should have the same name. 
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5 Click the Change button to join this workstation to the domain. 

6 Click the Domain selection button, enter your domain name in the Domain textbox, and 
then click OK. The Domain login window appears. 
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7 Enter the User Name and Password of a user with permission to join the domain. Enter 
“installer” for the User Name, and then enter the password you set when you created the 
“installer” account at the server, then Click OK. 

8 Click OK on both the Welcome to the Domain window, as well as the prompt to Restart 
the Computer. 

9 From the System Properties window, click OK, and then click Yes to Restart the 
Computer. 

 

Authenticate on the domain 

1 From the Windows login window, depress the CTRL-ALT-DEL keys on the keyboard. 

2 Make certain that your domain name is listed in the “Log on to:” textbox. (If you do not 
see a “Log on to:” field, click the Options button. 

3 Enter the User Name and Password in the appropriate textboxes for the user who will be 
running Pathways at this workstation, and then click OK. 

 

Note You must be logged onto the domain as “installer” in order to perform Pathways 
installation, Client Setup, or program updates. 

Access Rights 

One of the features of Windows XP Professional is increased security. System administrators 
have much greater control over user access to network resources as well as control over user 
rights and access to the local system. Pathways requires that users have Full Control of both 
the installation files that reside on the server as well as the Pathways directory that resides 
locally on each workstation. In order to install, or update the Pathways program, the user 
must have Administrator level access. This is due to the fact that during the installation or 
update, program components are being installed and entries are made to the Windows 
Registry. 

Note Administrator level access is only needed during Pathways installation, Client 
Setup and program updates. The monthly Data and Graphics CD’s can be run by any 
regular Pathways user. 
 
Important! Once Pathways is installed and Client Setup has been run, proper access 
rights will need to be applied to the local Pathways folder created during the Client 
Setup process. This includes the server if planning to run Pathways from that station 
as well. See the Network Installation & Update Guide for Pathways for details. 
  
You are now ready to proceed with the installation of your Pathways product. Please 
refer to the Network Installation & Update Guide for Pathways for more information. 
 
Note Prior to installing a Pathways product onto a network, the network operating 
system should be correctly installed and functioning on the server, and all 
workstations should be able to successfully attach and login to the server. A qualified 
computer technician should make any necessary adjustments. 
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Chapter 5 – Windows 2000 Professional Domain Client 
Configuration  

Configure the Workstations - Overview 
Verify that the server and workstations meet all minimum hardware and software 
requirements as published quarterly in the CCC Technical Requirements document. You can 
find this document located on the CCC website: http://www.cccis.com/. CCC strongly urges 
that the server and workstations meet or exceed our recommended hardware specifications to 
ensure the best performance. 

When a Network Interface Card (NIC) is installed, Windows 2000 will automatically install 
the following required network components. 

 Client for Microsoft Networks 

 File and Printer Sharing for Microsoft Networks  

 Internet Protocol (TCP/IP) 

 
These are the only components necessary to get the network up and running. And for the 
most part, all of the default settings for these components will work just fine. The only area 
that needs careful consideration is how you plan to assign TCP/IP addresses to your 
workstations. 

Note If your network is already set up and running correctly, and it is configured to 
use the TCP/IP protocol, then you may skip to the Configure Network Identification 
settings and join the domain section, later in this chapter. 
  
The type of TCP/IP addressing scheme needed for the workstations, is determined by the 
design that was previously chosen for the server.  

Choose from the list below, the same TCP/IP addressing scheme that was configured for the 
server, and then proceed to the appropriate section within this chapter. 

 ICS or Automatic Private IP Addressing 
 Static IP Addressing 
 

 

Configure clients for DHCP or ICS 

Whether you are going to use ICS or Automatic Private IP Addressing, the workstation 
configuration is identical. To verify that you have all of the necessary components and their 
configurations for this type of setup, follow these simple steps on each of your 2000 
Professional workstations: 

http://www.cccis.com/
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1 Log into Windows 2000 Professional as an Administrator. 

2 Click Start > Settings > Network and Dial-up Connections. 

3 Right-click the Local Area Connection, and then click Properties. 

4 Verify that the components listed below are present. (If not, you can use the Install button 
to add the missing components.) 

       

Note These are the only components necessary to get the network up and running. 
Additional components are not needed, and can probably be uninstalled. (Consult 
with your network technician to be certain.) 
 
5 Click the Internet Protocol (TCP/IP) component, and then click Properties.  

6 Click the “Obtain an IP address automatically” selection button, and then click the “Obtain 
DNS server address automatically” selection button.       

7 When you are finished making changes, click OK to close the Internet Protocol (TCP/IP) 
Properties sheet. 

8 Click OK to close the Local Area Connection Properties. 

Note If the above section was just completed, skip to the Configure Network 
Identification settings and join the domain section later in this chapter. 
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Configure Static IP Addressing 

To configure your Windows 2000 Professional clients with Static IP addresses, please follow 
these steps: 

1 Log into Windows 2000 Professional as an Administrator. 

2 Click Start > Settings > Network and Dial-up Connections. 

3 Right-click the Local Area Connection, and then click Properties. 

4 Click the Internet Protocol (TCP/IP) component, and then click Properties. 

5 Click the “Use the following IP address” selection button. 

       
6 Enter the IP Address and Subnet Mask values in the appropriate fields as shown above, 

and then click OK. 

CCC recommends using a non-routable address range such as the following: 

Subnet Mask: 255.255.255.0 
Peer Server:  169.254.0.1 
Workstation 1: 169.254.0.10 
Workstation 2: 169.254.0.20 
 

Important! Each system on the network must be configured with a unique IP 
address. 
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Configure Network Identification Settings and Join the Domain 

1 Log into Windows 2000 Professional as an Administrator. 

2 Click Start > Settings > Network and Dial-up Connections. 

3 Click Advanced from the menu bar at the top of the window, and then click Network 
Identification. 

       
4 From the Network Identification tab, verify that the workstation has a unique computer 

name (e.g., Workstation1). No other computer on your network should have the  
same name. 
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5 Click the Properties button to join this workstation to the domain. 

6 Click the Domain option in the Member Of tab, enter your domain name, and then click 
OK. The Domain login window appears. 

       
 



53 

7 Enter the User Name and Password of someone with permission to join the domain. 
Enter  “installer” for the User Name, and whatever password you set when you created 
the “installer” account at the server, then Click OK. 

8 At the Welcome to the Domain window, click OK. Click OK to restart the Computer. 

9 From the System Properties window, click OK, and then click Yes to restart the 
Computer. 

Authenticate on the domain 

1 From the Windows Logon window, depress the CTRL-ALT-DEL keys on the keyboard. 

2 Make certain that your domain name is listed in the “Log on to:” field. (If you do not see a 
“Log on to:” field, click the Options button. 

3 Enter the User Name and Password for the user running Pathways at this workstation, 
and then click OK. 

Note you must be logged onto the domain as “installer” in order to perform Pathways 
installation, Client Setup, or program updates. 

Access Rights 

One of the features of Windows 2000 Professional is increased security. System 
administrators have much greater control over user access to network resources as well as 
control over user rights and access to the local system. CCC Pathways requires that users 
have Full Control of both the installation files that reside on the server as well as the 
Pathways directory that resides locally on each workstation. In order to install, or update the 
CCC Pathways program, the user must have Administrator level access. This is due to the 
fact that during the installation or update, program components are being installed and entries 
are made to the Windows Registry. 

Note Administrator level access is only needed during Pathways installation, Client 
Setup and program updates. The monthly Data and Graphics CD’s can be run by any 
regular Pathways user. 
 
Important! Once Pathways is installed and Client Setup has been run, proper access 
rights will need to be applied to the local Pathways folder created during the Client 
Setup process. This includes the server if planning to run Pathways from that station 
as well. See the Network Installation & Update Guide for Pathways for details. 
  
You are now ready to proceed with the installation of your Pathways product. Please 
refer to the Network Installation & Update Guide for Pathways for more information. 
 
Note Prior to installing a CCC Pathways product onto a network, the network 
operating system should be correctly installed and functioning on the server, and all 
workstations should be able to successfully attach and login to the server. A qualified 
computer technician should make any necessary adjustments. 
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